Tutoriel JFusion : Intégrer un forum PhpBB à votre site Joomla

Slabre 6 novembre 2010 57 commentaires (A votre tour !)

Dernière mise à jour : 08/05/2011.
A l’attention de tous :
Inutile de me spammer pour le support de ce tutoriel. Je ne pourrais pas répondre à toutes vos questions…

Introduction

Chez moi, quand j’explique quelque chose, j’aime bien partir de zéro pour que tout le monde comprenne. Alors c’est ainsi que je vais procéder ! Dans ce tutoriel, je vais vous apprendre étape par étape comment intégrer un forum puissant PhpBB 3 sous Joomla! à l’aide d’un composant extraordinaire : j’ai nommé JFusion.

Joomla!, c’est quoi ?

Avant tout, un CMS est un ensemble de logiciels destinés à la conception d’un site web et de sa mise à jour. Joomla! c’est donc un CMS gratuit, libre et open source, qui offre des fonctionnalités intéressantes tels des news, des sondages, des recherches, etc.

On a la possibilité d’ajouter ce qu’on appelle des modules, des petits logiciels que l’on peut installer pour ajouter des fonctionnalités. Comme il est libre, tout le monde peut développer son propre module.

Et JFusion, c’est quoi ?

J’en parlais juste au-dessus ! JFusion est un module, mais pas n’importe quelle type de module. On appelle ça un bridge (« pont » en anglais), qui permet de faire une liaison (d’où le « pont ») entre deux CMS différents.

JFusion sert donc à faire une liaison entre Joomla! et ces autres CMS :

  • DokuWiki
  • eFront
  • Gallery2
  • Magento
  • Moodle
  • OsCommerce 2 & 3 & Max & SEO &XT & Zen
  • PhpBB
  • SMF
  • VBulletin
  • WordPress 3

Moi, ma mission est de vous apprendre comment lier Joomla! et PhpBB, certainement le CMS de Forum le plus connu à ce jour. Alors c’est parti !

Installation de Joomla!

Sans Joomla!, on ira pas bien loin. Moi, je vous conseille d’installer les dernières versions, actuellement les 1.5.X. Vous aurez largement plus de facilité de passer en 1.6, version qui va d’ailleurs apporter son bon lot de nouveautés (cette version est pour l’instant seulement disponible en anglais). Rendez-vous sur cette page (site officiel) pour télécharger la dernière version : Cliquez ici.

Cette partie, c’est la plus simple. Et pour l’installation de notre pilier dans ce tutoriel, je vous recommande le Manuel d’installation (en PDF) de l’AFUJ (Association Francophone des Utilisateurs de Joomla!).

Notez qu’il faut bien évidemment se renseigner auprès de votre hébergeur pour connaitre vos logins, bases de données, etc. Surfez sur votre compte client et vous trouverez surement quelque chose qui correspond aux informations demandés.

Installation de PhpBB

Eh oui bien sûr… si on commence à négliger les bases du tutoriel, il risque bien d’être court 😛
Il faut donc installer PhpBB en version française, et comme pour Joomla, je vous conseille les dernières versions pour mettre à jour plus facilement et bénficier des dernières éventuelles corrections. Rendez-vous sur ce site pour télécharger la dernière version en date. Moi, personnellement, je l’ai installé dans un sous-dossier nommé « forums ». Comme cela, l’accès sera plus simple : http://www.monsite.com/forums/

Pour l’installation, je vous renvoie sur le site du traducteur officiel de PhpBB où la documentation est complète et explicite : Cliquez ici.

Toujours comme Joomla!, il faut renseigner les informations de votre espace d’hébergement dans l’installation.

Après ça, on passe à la suite. 😉

Installation du module JFusion

Ah… ça commence à devenir plus intéressant déjà !

Au préalable, il faut télécharger (« encore télécharger ! ») le module… bah oui il va pas apparaitre tout seul… seul Mimie Mathy peut le faire ça 😀
On télécharge la dernière version en date qui, heureusement, offrira au fil du temps une meilleure compatibilité et moins de bugs. C’est par ici pour télécharger.

  • Maintenant, rendez-vous dans votre installation Joomla!, direction le panneau d’administration (si si, je vous assure que c’est là qu’on installe).
  • Dans le menu, cliquez sur Extensions > Installer/Désinstaller.

  • Cliquez sur Parcourir et allez chercher l’archive JFusion que vous venez de télécharger.
  • Cliquez sur « Transfert de fichier & Installation« .
  • Et voilà, le module JFusion est installé.

Vous devriez donc arrivé sur cette page (image ci-dessous) qui vous dit que l’installation est terminé. Il est notamment indiqué les configurations a effectué.

Configuration de JFusion

Configuration de joomla_int

Pour que les liaisons fonctionnent, il faut faire des réglages. Par exemple, il faut définir le type de forum que l’on utilise. Mais tout d’abord, il faut configuré un plugin maitre et esclave.

  • Tout d’abord, rendez-vous dans Composants > JFusion > Configuration.

  • Dans la liste qui apparait, sélectionnez « joomla_int » et cliquez sur le bouton () pour le configurer. Vous pouvez vous y rendre plus rapidement via Composants > JFusion > Joomla Options.

Là, on vous renvoie de suite sur une page qui sert de configurations à « joomla_int ». Il va donc falloir configurer le tout. Ci-dessous, les configuration à effectuer :

Plugin General Details

  • Description : nom du plugin (peu importe),
  • URL complet vers le logiciel intégré : il faut indiquer l’URL où se trouve votre installation Joomla (ex : http://www.slabre.fr).

Login Options

  • Identificateur de connexion : Identifiant,
  • Filtre de l’identifiant : joomla_int.

User Options

  • Avant de configurer ce bloc, il faut sauvegarder les modifications. Faites-le et revenez dans l’édition de joomla_int,
  • Groupe d’utilisateur mode : Simple,
  • Groupe d’utilisateur par défaut : REGISTERED.
  • Sauvegardez les modifications.

joomla_int étant configuré, vous pouvez d’ores et déjà le définir comme plugin maître. Pour cela, rien de compliqué je vous rassure, il suffit de cliquer sur la croix rouge dans la colonne « Maître ». 2 autres colonnes ont notamment été activés pour ce plugin, c’est normal, pas la peine d’y toucher.

Désactivation des inscriptions dans le forum

Avant de passer à l’étape suivante, il va falloir désactiver l’inscription via le forum. Pour se faire :

  • Il faut se rendre dans « Paramètres des inscriptions » sur la page d’accueil du panneau d’administration de votre forum PhpBB.

  • Dans le champ « Activation de compte », choisissez « Désactiver »,
  • Cliquez sur « Envoyer » en bas de la page pour sauvegarder.

Configuration du plugin phpbb3

Maintenant, on va pouvoir configurer le plugin esclave, c’est-à-dire notre forum : le plugin phpbb3.

  • Dans la liste des plugins, on clique sur le bouton de configuration () pour configurer le plugin.

  • Il faut indiquer le chemin où se trouve le forum. Dans mon cas, je dois juste ajouter « /forums« . Cliquez sur Suivant,

Plugin General Details

  • Descritpion : Nom de votre plugin (peu importe…),
  • URL vers le logiciel intégré : Renseignez l’adresse où se trouve votre forum (attention pas de sous-domaine !),
  • Chemin complet vers le logiciel intégré : chemin absolu de votre forum (ex : home/slabre/forums) mais déjà rempli normalement,
  • Rendez vous dans l’administration de votre forum, allez dans Général > Configuration du serveur > Paramètres de cookie,
  • Terminez de renseigner le bloc Plugin General Details avec les informations affichés,
  • Durée de session : 60 minutes par défaut,
  • Autorisez la Connexion Automatique par Cookie : Activé,

     

  • Cliquez sur Sauver.

Database Options

  • Renseignez tout simplement les informations qui permettront la connexion à la base de données de votre forum.

Login Options

  • Identificateur de connexion : Identifiant,
  • PHPBB_LOGIN_TYPE : PHPBB_LOGIN_DIRECT.

User Options

  • Sauvegardez les modifications et revenez à l’édition du module phpbb3,
  • Groupe d’utilisateur mode : Simple,
  • Groupe d’utilisateur par défaut : REGISTERED.

Mod/Plugin Options

  • Activez le show_auth_mod et ne changez rien d’autre.

Après avoir effectué tout ça, on peut le mettre en « esclave« . On clique donc sur la croix rouge dans la colonne adéquate qui nous permet de le faire.

Testons la connexion

JFusion nous propose de tester les connexions des liaisons que nous avons préalablement configurées avant de publier les plugins nécessaires à son fonctionnement sur le site.

  • Rendez-vous dans Composants > JFusion > Login Checker,

  • Insérez votre identifiant et votre mot de passe dans les champs prévus (aucune case n’est à cochée),
  • Cliquez ensuite sur « Vérifier la connexion » en haut à droite.

Si vous ne voyez aucun message d’erreur et des beaux  , c’est que tout est bien configuré et que nous sommes prêt pour l’étape suivante. Si par malheur vous avez un message d’erreur, je serais là pour vous répondre dans les commentaires, et je répondrais du mieux que je peux.

Publication de JFusion sur le site

Activation des plugins nécessaires

Les plugins activés pour la connexion au site sont encore ceux de Joomla. Donc si on se connecte, on ne sera identifié que sur le site. On va donc remédier à cela et changer les plugins :

  • Allez dans Composants > JFusion > Cpanel,

  • Vous remarquerez qu’il y a un message d’erreur assez important :

  • Pour y remédier, il faut tout simplement cliquez sur « Enable the JFusion Plugins« ,
  • Un message à titre informatif apparait, ignorez-le en cliquant sur « OK« ,
  • Vous obtiendrez donc ce message à la place, qui est bien plus agréable :

Et voilà, les plugins nécessaires au fonctionnement de JFusion sont maintenant activés. Chaque utilisateur qui s’enregistrera sera inscrit sur le site et le forum, et chaque utilisateur qui se connecte sera connecté sur le site et le forum. C’est taupe coule 😀

Différents affichages de JFusion

Publication du module de connexion

Si ce n’est pas déjà fait, il faut publier un petit bloc qui permettra de se connecter, ou encore de s’inscrire au site et au forum. Ci-dessous, la marche à suivre pour l’intégrer :

  • Il faut aller dans Extensions > Gestions des modules,

  • Dans la liste des modules, il y a un certain « JFusion Login Module« , cliquez dessus pour l’éditer,
  • Renommez le titre (moi j’ai mis « Connexion ») et dans le champ « Activé », sélectionnez Oui.
  • Cliquez sur Sauver et admirez votre page d’accueil doté d’un module de connexion.

Personnalisation du module de connexion

Il est possible de personnaliser le module de connexion afin que ce dernier soit plus utile. Pour se faire, il faut d’abord retourner dans l’édition du module, là on nous avons précédemment changer le titre et l’activation. On va effectuer des modifications sur la colonne de droite de la page du module, appelé « Paramètres du module ». Voici les champs expliqués un par un, où ceux en gras sont obligatoires :

  • Texte avant : ajouter un texte avant les champs de connexion, même connecté,
  • Texte après : ajouter un texte après les champs de connexion, même connecté,
  • URL de redirection après connexion : la page où nous sommes dirigés après la connexion,
  • URL de redirection après déconnexion : la page où nous sommes dirigés après la déconnexion,
  • Afficher le nom ou l’identifiant : affiche le nom ou l’identifiant lorsque nous sommes connectés,
  • Formulaire de connexion crypté : permet une connexion sécurisée,
  • Se souvenir de moi : permet la connexion automatique lorsque la case est coché à la connexion,
  • VIEW_MODE : affichage du module horizontalement ou verticalement,
  • ID de l’item : choisir Phpbb3 en cliquant sur « Select »,
  • Custom lost password URL : permet l’affichage d’un lien personnalisé pour récupérer son mot de passe,
  • Mot de passe perdu : affiche un lien de secours lors de la perte du mot de passe,
  • URL de nom d’utilisateur perdu : permet l’ajout d’un lien personnalisable lors de la perte du nom d’utilisateur,
  • Identifiant perdu : affiche un lien lors de la perte de du nom de l’identifiant,
  • Custom Registration URL : permet l’affichage d’un lien personnalisé pour s’inscrire,
  • Créer un compte : affiche un lien pour l’inscription,
  • Bienvenue : affiche le message d’accueil,
  • Avatar : affiche l’avatar configuré dans le profil du forum (il faut activer les avatars dans le forum),
  • AVATAR_HEIGHT : configuration de la hauteur maximale de l’avatar,
  • AVATAR_WIDTH : configuration de la largeur maximale de l’avatar,
  • A partir de quelle application récupérer l’avatar : mettre JFusion par défaut,
  • Plugin JFusion : choisir phpbb3 en cliquant sur Select,
  • Compteur de message privé : affiche le lien vers votre boîte de réception,
  • Lien des nouveaux messages privés : affiche le lien des nouveaux messages du forum.

C’est quand même génial, non ?

Afficher le forum dans votre site

JFusion donne aussi la possibilité d’afficher directement votre forum dans le contenu du site. Dans cette partie, je ne pourrais pas vous aider car elle est surtout graphique. En effet, l’adaptation du design et notamment la largeur du forum pour certains thèmes est très compliqué. C’est pourquoi je vous conseille de laisser le forum hors du site pour une bien meilleure lisibilité, et créer un design semblable à celui du site.

  • Avant tout, il faut créer une page « Forum ». Direction Menus > Main Menu (ou autre menu),
  • Cliquez sur « Nouveau » et cliquez sur JFusion dans « Lien interne »,

  • Choisissez son titre, son alias, l’endroit d’affichage, et choisir qu’il est publié.
  • Dans le bloc de droite (« Paramètres – Basique »), configurez le « Plugin JFusion » en sélectionnant phpbb3.

Les autres options sont des choix personnelles étant donné qu’il concerne l’affichage. Je peux juste dire que « Frameless » n’affiche pas des barres de défilement, et le contraire pour « Encapsuleur ». En revanche, préférant Frameless, je trouve dommage que le CSS pose problème (je vous laisse découvrir…).

Configurer un lien externe

Comme je vous ai conseillé de laisser votre forum hors du site, on va créer un lien dit externe au site afin de se rendre sur le forum d’un simple clic de souris.

  • Se rendre dans Menus > Main Menu (ou autre menu),
  • Cliquez sur « Nouveau » en haut à droite,
  • Sélectionnez « Lien Externe »,

  • Choisissez son titre, son alias, l’endroit d’affichage, et choisir qu’il est publié.
  • Et bien sûr n’oublier pas d’ajouter le lien dans le champ prévu : il sera suffisant d’ajouter « /forums/« , ou bien si vous préférez ajouter le lien complet « http://www.monsite.com/forums/ ».

Et voilà, vous pouvez désormais accéder à votre forum en cliquant sur le lien. Maintenant, à vous de jouer en faisant un thème pour votre forum semblable à votre site.

Note importante

Sachant que vous avez installé le forum et le site avant JFusion, vous serez exclusivement le seul membre de votre site et de votre forum à avoir deux comptes différents. Pour « lier » les comptes, je vous suggère tout simplement de mettre le même pseudo et mot de passe sur votre Joomla et PhpBB 3. Ainsi tout sera réglé…

Conclusion

Ce tutoriel touche à sa fin ! Oui, déjà !
J’ai vraiment pris du plaisir à faire ce tutoriel et je suis très content que ce dernier va certainement en aidé plus d’un. Je ne vous précise plus que pour le support, toutes les questions sont les bienvenus dans les commentaires et je tenterais d’y répondre aussi bien que je le pourrais.

Merci à tous pour votre fidélité !

  • Pingback: Les tweets qui mentionnent TUTORIEL – Intégrer un forum PhpBB à Joomla! avec JFusion RT PLZ -- Topsy.com()

  • Plotek

    Bravo Slabre pour ce superbe tutoriel.
    Je viens de signaler son existence sur le forum joomla!fr (http://forum.joomla.fr/showthread.php?134686-TUTORIEL-%C2%96-Int%C3%A9grer-un-forum-PhpBB-%C3%A0-Joomla%21-avec-JFusion).
    J’y expose en outre un problème que je ne parviens pas à résoudre, lié à la déconnexion de phpbb3 lorsqu’un visiteur utilise se déconnecte à partir de phpbb3 !

    • Merci beaucoup à toi Plotek !

      Pour ton soucis, il te suffit d’éditer le fichier « overall_header.php » de ton thème (styles/nom_du_theme/template/overall_header.php) et supprimer la ligne suivante (ou quelques chose du genre, tout dépend ton thème) :

      lien -> http://d28.e-loader.net/uavN5P2RTY.txt

      Surtout, n’oublie pas de rafraichir les « templates » via le panneau d’administration du forum. 😉

  • Sana

    je me suis bloqué à létape : Configuration du plugin phpbb3
    j’ai comme msg d’erreur:
    Erreur: le chemin source du plugin JFusion n`a pas été trouvé
    phpbb3: users: La table Utilisateur n`a pas été trouvée

    Pourriez vous m’aider svp?

  • Sana

    mnt j’ai que cette erreur
    phpbb3: users: La table Utilisateur n`a pas été trouvée

    qu’est ce que je doit faire svp? :'(

    • Peux-tu m’indiquer à quelle étape es-tu ? 😉

      • Sana

        je suis a l’étape : Configuration du plugin phpbb3
        , lorsque je valide les modif ( j’ai bien suivi le tuto) je recoit ce msg d’erreur dès que je clique sur sauver:

        phpbb3: users: La table Utilisateur n`a pas été trouvée

        merci d’avance

        • Au lieu de mettre des antislash, mets des slash tout court 😉

          • Sana

            J’ai essayé de mettre un slash, mais j’ai tjr le même prob , tjr le même message d’erreur :'( La table Utilisateur n`a pas été trouvée

            je commence a desespérer :'(

    • Alors peux-tu me fournir un screenshot (ou plusieurs ce sera mieux) de ton soucis ? Ce sera mieux pour que je t’aide.. 🙂

  • Sana

    je profite pour poser d’autres question 🙂 comment je peux créer des commentaire? comment modifier la fovicone? comment je peux définir ma propre template? merci d’avance et désolé pour le dérangement , je suis débutante et je me galère toute seule 🙁

    • Pour les commentaires => http://www.joomlafrance.org/Les_News/Composants/Les_commentaires_en_ajax…_avec_Chrono_Comments.html

      Pour le favicon, il te suffit de changer l’image « favicon.ico » qu’il y a dans ton template.
      S’il n’y en a pas, je t’envoie à ce lien pour le faire et ajouter la ligne de code qu’il faut dans header.php, toujours dans le dossier de ton template.

      • Sana

        pr le favicon, merci bcp, j’ai trouvé ce liens pr convertir une image en favicon rapidement : http://tools.dynamicdrive.com/favicon/
        et la ligne a ajouter dans le index.html du dossier template est le suivant 🙂

        • Je te conseille de l’ajouter dans header.php, comme ça tu l’auras sur toutes les pages. 😉

  • Stefen

    Bonsoir,

    J’ai un petit problème.

    Tout a bien fonctionné en suivant votre tutorial (qui est très bien expliqué par ailleurs) seulement lorsque je veux publier le forum sur le site en choissisant « frameless » il me met un message d’erreur quand je vais sur le forum sur le site. Comment cela se fait-il ?

    PS : en wrapper cela fonctionne mais évidemment j’aimerai qu’il soit frameless afin que les urls puissent être utilisés et donc référencés.

    Merci d’avance.

    • As-tu bien choisi « phpbb3 » dans le champ « Plugin JFusion » ? 😉

      • Stefen

        Voilà ce que ca me met quand je vais sur la page du forum lorsqu’il est en frameless :

        « The path to the requested does not exist
        Le output buffer n`a pas été généré par le plugin JFusion. »

        Une idée ?

        Merci d’avance c’est sympa.

        • Tu n’as pas répondu à ma question…

  • Pingback: Du (très) gros prochainement sur le blog (et bonne année !) | Slabre.fr()

  • Stan’

    Bonjour,

    Je ne trouve nul part l’information d’une éventuelle compatibilitée entre jfusion et un forum externe style xooit.

    En effet, je dispose d’un forum xooit depuis quelques mois et je viens de faire un portail joomla, j’aimerais que lorsque je me log sur joomla ca me log sur le forum.

    Est-ce possible ?

    Merci par avance,
    Stan’

    • Stan’

      Finalement, je pense avoir une réponse en lisant certain pour sur les forums de xooit.

      Apparement leur base de donnée n’est accessible que par eux, je suppose donc que jfusion n’est pas compatible.

      J’espere me tromper.
      Stan’

      • Slabre

        Non désolé tu ne te trompes pas, xooit est un hebergeur de forums gratuit qui ne te donne pas d’accès au http://ftp...

  • Wil

    Salut et mille merci pour ce tuto !
    J’ai TOUT configuré sans aucuns soucis !

    Maintenant j’ai un autre probleme, lorsque je vais a la page d’accueil de mon site j’ai toujours la base de Joomla, je ne vois pas mon forum dessus.
    Coment faut-il faire pour que mon forum soit sur l’index ?
    Encore un grands merci.

    • nonno

      bonsoir,
      voilà j’ai tout installé proprement je pense, la connections et déconnexion de joomla et de forum sont bien syncro, par contre lorsque je me connecte au forum via le site joomla je suis bien connecté au forum mais je suis considéré comme un visiteur certaine parti du forum met inaccessible me disant que je n’ai pas les droits.
      cordialement.

      • Flo

        idem j’attends la solution avec impatiente depuis plus d’un mois. On est tous avec toi !!!!

        je pense qu’un peu d’encouragements font toujours plaisir.

        • Merci, c’est sympa ! Je vous promets que la mise à jour arrive dans peu de temps, réellement. 🙂

  • Alain

    Bonjour et un très grand bravo pour le tuto.
    N »anmoins je rencontre le PB suivant :
    Dans ma config je n’arrive pas à activer l’inscription via le plug « joomla_int » et j’ai toujours le messsage dans l’admin :  » joomla_int: nécessite d`activer l`inscription des utilisateurs car c`est le maître »
    Je te joints des screens.
    Merci pour ton aide
    Alain

  • Bernard

    Dans ma config je n’arrive pas à activer l’inscription via le plug « joomla_int » et j’ai toujours le messsage dans l’admin : » joomla_int: nécessite d`activer l`inscription des utilisateurs car c`est le maître »

    J’ai exactement le meme probleme et ca fait deux jours que je cherche 🙁 Qui peux nous aider svp ? Merci d’avance

  • Joyrock

    Excellent tutoriel, cependant j’ai un soucis, lorsque je fais le check de connexion il me dit que tout est ok. Je me connecte donc au portail et jusque là tout va bien je suis authentifié.
    Mais lorsque je clik sur mon menu puis lien forum, je dois me ré-authentifier sur le forum…

    Les cookies sont exactement configurés à l’identique, j’ai testé en secure et non secure… rien n’y fait 🙁

  • Bonjour,

    Je tenais tout d’abord à te dire un grand bravo, tuto super simple à comprendre. Pas besoin de s’y reprendre à 2 fois.
    Toutefois, (et oui …) j’ai un souci. J’ai mis mon forum dans un Wrapper afin d’avoir le forum intégré dans le site car c’est quand même plus jolie et je m’aperçois qu’il est dans un tout petit carré au lieu de remplir l’entièreté du corps du site… J’ai tenté les bidouilles avec les réglages mais rien y fait. Auriez-vous une solution pour remédier à mon problème ?

  • Bonjour,
    j’ai suivi scrupuleusement le tuto et j’ai l’erreur suivante lorsque je tente d’activer le show_auth_mod :

    Warning: fopen(/home/loca/public_html/forum/includes/auth/auth_jfusion.php) [function.fopen]: failed to open stream: No such file or directory in /home/loca/public_html/libraries/joomla/filesystem/file.php on line 240

    Warning: file_put_contents(/home/loca/public_html/forum/includes/auth/auth_jfusion.php) [function.file-put-contents]: failed to open stream: Permission denied in /home/loca/public_html/libraries/joomla/filesystem/file.php on line 298

    Fatal error: Call to a member function setQuery() on a non-object in /home/loca/public_html/administrator/components/com_jfusion/plugins/phpbb3/admin.php on line 399

    Merci de votre aide

  • Bonjour,

    Même problème que Leroy…

    J’espère que vous trouverai la solution à ce problème.

  • Bonjour, comme expliqué dans le message rouge tout en haut de l’article, je ne fais plus beaucoup de support pour ce tutoriel… et malheureusement je n’ai pas du tout réponse à votre problème.

    Désolé.

  • Ali

    Merci beaucoup, cela m’a vraiment servi et aidé. Très bien expliqué. Que Dieu te récompense.Merci encore une fois

  • tbr

    Bonjour et merci pour cet excellent tutoriel !

    Perso, j’ai un forum phpbb3 avec de nombreux membres et messages et je suis en train de créer un site avec joomla.

    Comment faire pour avoir mes membres phpbb dans joomla?

    Cordialement,

    • Salut,

      Alors je n’ai jamais eut à faire face à cette situation… mais avant tout manipulation avec JFusion, fais un backup de ton forum. Ensuite, essaie de suivre le tutoriel… si ça marche, tant mieux, si ça marche… il y a forcément une solution.

      A+ 😉

  • tbr

    Faut t il utiliser la même base de donnée pour le forum et le blog ?

    • Oui très certainement, je pense pas qu’on puisse dupliquer des infos d’une base à une autre… ou alors il faut s’y connaitre en mysql hors ce n’est pas mon cas ^^

  • muse

    Je voudrais te dire un gros merci Slabre
    j’ai suivi ton tuto de A à Z, et tout s’est deroulé comme indiqué, et fonctionne pour le mieux.

    Encore un grand Bravo, et bonne continuation !

    • Ravi de l’entendre ! C’est moi qui te remercie 🙂

  • Bonjour,
    Lorsque j’active le module d’identification de Jfusion, j’ai cette erreur sur mon site en Fronted :
    Fatal error: Class ‘fonctionGmaccess’ not found in /mnt/154/sdb/4/6/albarj/libraries/joomla/application/menu.php on line 279

  • Que du bonheur… ça marche du premier coup

    Chapeau Slabre et merci à toi pour le super boulot que tu a fait!!!

  • Bonjour,

    J’ai installé Jfusion sur mon site et j’ai un petit soucis lorsque je me log sur le forum ( phpbb3) j’ai une erreur sql

    Fatal error: Call to a member function obtain_bots() on a non-object in C:\wamp\www\globalesport\forum\includes\session.php on line 508

    Je ne vois pas d’ou ça peut venir 🙁

    Auriez-vous une petite idée ?

    Merci d’avance

  • Victor

    Avec Joomla 1.7 et PhpBB3 lors du loging checker de JFusion, il se peut que vous aillez des erreurs PHP.

    Pour résoudre ça commentez les lignes des fonctions re-déclaré dans phpbb3/includes/utf/utf_tools.php

  • Bonjour,

    C’est joomla 1.5 qui est installé sur mon site.

    Pour les lignes a commenté je ne vois pas très lesquelles sont à commentés si quelqu’un pourrait éclairer ma lanterne 😉

    http://www.global-esport.com/forum

    Cordialement,

  • Bonjour,

    quand je désactive le show_auth_mod ça remarche bizarre

    😉

  • bonjour =)

    je suis sur joomla (1.7.1) et phpbb (3.0.9)
    et j’ai exactement les erreurs que Victor cite.

    Fatal error: Cannot redeclare utf8_strrpos() (previously declared in /homez.466/wolfcamq/www/libraries/phputf8/mbstring/core.php:63) in /homez.466/wolfcamq/www/forum/includes/utf/utf_tools.php on line 122

    Mais je suis désolé, je ne vois pas ce que tu entend par commenter les lignes !!

    merci d’avance !

  • Dansimati

    Quand je fais le contrôle de connexion, tout fonctionne, à part tout à la fin, où il me dit ça:

    Fatal error: Cannot redeclare utf8_strrpos() (previously declared in /home/www/f569f31f94be128cd394b39f165b9157/web/2012/joomla/libraries/phputf8/mbstring/core.php:63) in /home/www/f569f31f94be128cd394b39f165b9157/web/2012/joomla/forum/includes/utf/utf_tools.php on line 122

    • MCS08

      Pareil, même problème…

  • MCS08

    J’ai réglé tout les pbs mais dans ton truc y’a un gros bleme que tu indiques pas. Si tu désactives les inscriptions phpbb plus personne peut s’inscrire avec la config que tu proposes (le menu s’enregistrer continu toujours de pointer vers le forum)…

  • FOB

    Même problème que spider.
    Joomla 1.5

    « Call to a member function obtain_bots() on a non-object in… »

    quelqu’un a une solution ?

    B.

  • Kévin

    Bonjour, mon forum est lié par un bridge avec joomla via Jfusion.

    mon site est en local (localhost:port/site)

    cependant lorsque je me connecte au forum je me retrouve avec un page blanche avec l’URL suivante : localhost:port/phpBB3/ucp.php?mode=login

    idem lorsque je tente de me connecter au forum depuis mon site avec l’URL suivante :
    localhost:port/site/index.php/forum

    Si vous avez une idée ou deux …

    Merci

  • Bonjour/bonsoir !

    Je voulais dans un premier temps te remercier pour le temps consacré à la rédaction du ce tutoriel ! il est simple de compréhension et facile d’accès.
    en le suivant je n’ai eu aucun problème le bridge fonction bien dans les deux sens à l’exception du fait que quand un nous utilisateur veut s’inscrire il tombe sur la page d’inscription de phpbb3 et se retrouve dans l’impossibilité de s’inscrire, puisque les inscriptions sont désactivés sur phpbb.
    Je suis sous phpbb3.0.11 et Joomla 2.5 merci d’avance si quelqu’un à une réponse ^^

  • Its superb as your other content : D, thanks for posting . « What makes something special is not just what you have to gain, but what you feel there is to lose. » by Andre Agassi. LegAndArmExercisesForBedRest http://sdjweokdquw.wikispaces.com/LegAndArmExercisesForBedRest

  • Bonjour, je ne parviens pas à trouver le fichier auth_jfusion.php à mettre dans phpbb3, version joomla 2.5 & phpbb 3.0.11

    Merci d’avance.

  • Un grand merci pour l’auteur du tuto ! J’aime bien le principe « partir de zéro pour que tout le monde comprenne » :)) Pour moi tout est fonctionné, c’est top !

  • Didier Depoilly

    bonjours a tous
    j’ai installé joomla et phphb3 avec js fusion , tout semble fonctionné sauf une chose , le lecture des message du forum ( file not found ) sur mes topics,